Installation & Upgrades

Latest PDFDataNet Release & Technical Requirements

The latest version release of PDFDataNet is v7.2026.9.9:

The details required for your server or client machine are as followed:

  • Read/Write/Modify permissions to the folders PDFDataNet will access/process
  • Firewall open for access to: IP Address: 51.104.43.133, Port: TCP 8000
  • Supported Client Operating Systems: Microsoft Windows 11, 10, 8.1, 8
  • Supported Server Operating Systems: Microsoft Windows Server 2022, 2019, 2016, 2012 R2, 2012, 2008 R2 SP1
  • Microsoft .Net Framework: 4.8
  • Processor: 1 GHz
  • Memory: 512 MB
  • Available Disk Space: 4 GB

1. Program Install

Download Link

Download and install PDFDataNet from here.

Had an issue after upgrading to version 7 of our program? Here’s a copy of version 6.2022.04.26 to download. We also have version 7.2025.02.13 available to download.

Run Installation File

Download and run the PDFDataNet install file (PLEASE NOTE: on the Select Additional Tasks screen make sure to tick Register for Settings automatic updates, then set the Badge as: ADDTHEIRSETTINGSBADGEHERE and keep clicking next/finish until the end of the install)

Having downloaded the installation file, open and run this file and follow the on-screen instructions.

Make sure to do the following during this installation:

  • Tick the Register for Settings automatic updates (this should be automatically ticked for you)

  • Add your Automatic Settings Manager badge to the badge provided via the support portal

Activate PDFDataNet License

Please follow instructions on this page, under the “Set-up OiC License Supervisor” head, for adding your license to our Document Indexing and OiC License Supervisor programs.

Documentation & Support
You can access documentation here – which includes online guides and videos on how to use our programs.

We provide support via our online portal. You will need to register and be approved in order to access this area of our website as it is limited to client’s only.

2. Program Upgrade

Create A Backup

Please follow the instructions under 4. Create Backup for how to do this.

We strongly recommend taking a backup of the Program and your Settings before proceeding with program upgrades.

Close Programs

It’s important that all PDFDataNet related programs are closed (Document Indexing and Configurator).

If you are running the Universal Service Monitor service (previously known as DI Monitor) please stop this before running the upgrade installation file.

Have an older version of the program? Click here.

To stop the Universal Supervisor Monitor (Service) from running, please open the program and click the Stop button. You can then close this window.

Download & Install Upgrade

Download and run the latest version of PDFDataNet from here.

Please Note – if you haven’t registered for automatic settings updates:

On the Select Additional Tasks screen make sure to tick Register for Settings automatic updates, then set the Badge (please open a ticket on the support portal if you need this provided).

Restart Programs

Once the upgrade is complete you can then re-open the Document Indexing program.

Have an older version of the program? Click here.

If you had the Universal Supervisor Monitor (Service) running, please re-open the program and click the Start button to resume the service.

3. Import Templates

Create A Backup

Please follow the instructions under “Create Settings Backup“, “4. Create Backup“, for how to do this.

We strongly recommend taking a backup of the Settings before proceeding.

Download & Import Templates

A zipped templates folder will be provided to you via our online portal (you don’t need to unzip the contents of this folder).

Having downloaded the template files, please copy the zipped folder into a folder of your choice – for example your Documents folder.

It’s important that the Universal Service Monitor program is stopped before importing your settings. To stop the Universal Service Monitor from running, please open the program and click the Stop button. You can then close this window.

Then open Document Indexing and go to Help > Settings > Import Settings.

A dialogue box will then appear, simply find the zipped folder from the location you saved it in and click Open.

Testing Your Templates

Have an older version of the program? Click here.

If you had the Universal Supervisor Monitor (Service) running, please re-open the program and click the Start button to resume the service.

We recommend closing and re-opening Document Indexing – as this helps refresh the program.

You can then begin testing the new/fixed templates by dragging a PDF into Document Indexing or by going to File > Open PDF.

Providing Feedback On Templates

We’ll await your feedback following testing of the system/templates – via our support portal. If you run into any issues please send us the following so that we can look to resolve this for you:

  1. A copy of the issue source file(s).
  2. Relevant screenshots/error messages.
  3. A description of the problem:
    1. If it’s an extraction issue tell us which field(s) are incorrect and what the values/exported data should actually contain.
    2. If it’s a program issue tell us what you did and what that resulted in. Please also tell us what program version you are using – to find this out visit: https://pdfdatanet.com/documentation/release-notes/#version
  4. Lookup/transformation files (if necessary or if they have been changed/updated).
  5. A zip containing all the log files from here: C:\ProgramData\OIC\PDFDataNet\Logs

4. Create Backups

Create Program Backup

Have an older version of the program? Click here.

Open Document Indexing and go to Help > Program Versions > Create Program Backup.

A dialogue box will then appear where you can choose the folder where you will Save it. By default it will save it in the following file path: C:\ProgramData\PDF Data Net_Archive

Restore Program Backup

Should you need to roll-back to a previous program version simply:

  • Close all PDFDataNet programs and Stop the Universal Service Monitor service (if running)
  • Open your program backup folder, Select all and Copy the files
  • Paste into the following file path: C:\Program Files\O Imaging Corporation\PDF Data Net
  • You can then Start the Universal Service Monitor service (if previously running) and re-open Document Indexing
Create Settings Backup
Have an older version of the program? Click here.

Open Document Indexing and go to Help > Settings > Create Backup.

A dialogue box will then appear where you can choose the folder where you will Save it. By default it will save it in the following file path: C:\ProgramData\PDF Data Net_Archive

Restore Settings Backup

Should you need to roll-back to a previous settings version simply find your settings backup (zipped file) and open Document Indexing and go to Help > Advanced > Import All Settings (this requires an import all, not a regular import) and import the settings.

Have An Older Version Of PDFDataNet?

Need support?

Visit the portal.

Pin It on Pinterest